Subject: Honey, Frozen Chicken & Beef

From: [email-masked] (Andy Nachbaur)
Date: Sat, 18 Feb 1995 05:43:00 GMT

*found road killed on the internet highway*

<>
This message was from Ab Mobasher <[email-masked]>

Mid Amber Honey From China @$1,250 MT
US Chicken $@985MT
Mongolian Beef @$1,655MT

For mor information please include your street address, Fax/ph.

<>

---

From: [email-masked] (Adam Finkelstein)
Date: 19 Feb 1995 04:02:14 GMT

>For mor information please include your street address, Fax/ph.

Andy: please tell us what this means.
Adam
-- 
______________________________________
Adam Finkelstein 
[email-masked]

---

From: [email-masked] (Norman R. Paterson)
Date: 27 Feb 1995 11:56:05 GMT

In article <[email-masked]>,
Adam Finkelstein <[email-masked]> wrote:
...
>Andy: please tell us what this means.

There are two puzzles about this message.

The first is what MT stands for.  I think it means metric tonne.
1 metric tonne = 1000 kilograms.  The prices are reasonable.

The second is why the poster thinks we want to know the prices per
metric tonne of Chinese honey, US chicken, or Mongolian beef.

What we really want to know is the price per cubic mile!  :-)

-Norman