Subject: Medical use of honey

From: [email-masked] (Helge Erik Solberg)
Date: 20 Dec 1994 12:31:45 GMT

A friend wants info on the medical use of honey. Where can he find it?

---

From: [email-masked] (Pollinator)
Date: 21 Dec 1994 09:13:02 -0500

Connie Krochmal has gone through a lot of the recent research, especially
in Europe, and has published a couple articles in the American Bee
Journal. You might check out the last year or so.
[email-masked].  Eastern Pollinator Newsletter, PO Box 1215,
Hemingway, SC.   Dave Green