Subject: WANTED MINATURE HEDGEHOGS (BREEDING STOCK)

From: Christine Roedding <[email-masked]>
Date: Thu, 25 May 1995 18:14:01 GMT

We are looking to purchase one to two pairs of Hedge Hogs for breeding 
purposes. If any one has any information in regards to the above, 
please contact the writer forthwith.

Thanking you in advance,
K. Richard McIntyre

Bus: (519) 284-0716
Email: [email-masked]

---

From: "John Scheuren (ADM)" <[email-masked]>
Date: Sat, 3 Jun 1995 18:49:58 -0400

I think I saw some at TOYS R US, some had rips, but most were OK.