Subject: Re: 1993 Honey Prices

From: [email-masked] (R John Northcote)
Date: Sun, 7 Aug 1994 01:18:06 GMT

Prices in US are usually by the pound (remember that quaint 
Measure?). Here in Canada we usually quote honey in pounds as
well (except for the government which uses Kilos). In 93
Canadian wholesale prices were in the 60-65 cents/pound 
range in 45 gal (CDN) barrels. At the time the exchange
rate was about 1 CDN$ = .79 US$ (currently 72 cnets).
-- 
R John Northcote
c/o National Capital Freenet

---

From: [email-masked] (R John Northcote)
Date: Sun, 7 Aug 1994 01:18:06 GMT