Subject: Beekeeping Suits

From: "[email-masked]" <ids.net>
Date: 13 May 1995 01:04:19 GMT

I own a one piece suit supplied from Dadant which has the veil and hat ATTACHED.  They've discontinued this model and only have the silly suits for which you have to buy the football helmet and veil.  Does anyone know where I can buy the good old-fashioned one piece model?

---

From: [email-masked]
Date: Sat, 13 May 1995 03:16:11 GMT

I've been using a one-piece Tyvek asbestos removal suit.  These suits have a 
built in hood and plastic face shield.  The plastic can be cut out and 
replaced with window screen by using duct tape to tape the screen in the 
opening.  These suits are intended to be single use but with a little care 
they can last for years.  They're also handy if friends want to watch.  The 
last I bought were around $10 fm Direct Safety