Subject: Beautiful Sand Dollar Stepping Stones

From: Mike Garibaldi <[email-masked]>
Date: 10 May 1995 07:02:17 GMT

Ciao!

Check out these wonderful, cast stone
giant sand dollar stepping stones at:

http://www.rain.org/~scultura/Sculpture.html

Take care,
Mike

---

From: Mike Garibaldi <[email-masked]>
Date: 10 May 1995 07:04:42 GMT

> http://www.rain.org/~scultura/Sculpture.html

Sorry, had an incorrect capitalization in the 
previous address... the cool stepping stones are at:

http://www.rain.org/~scultura/sculpture.html