Subject: AMERICAN OLEAN (usa) QUARRY TILES

From: [email-masked] (Yan Lee)
Date: Fri, 03 Nov 1995 07:27:29 GMT

I am looking for the contact number for the supplier of the above
tiles for import to malaysia

The company is in USA

Please email or fax me at 604 2628957

Regards

---

From: [email-masked] (Hannah Banks)
Date: Fri, 03 Nov 1995 07:43:57 -0500

> tiles for import to malaysia

American Olean: 1000 Cannon Avenue
                           P. O. Box 271
                           Lansdale, PA 19446-0271
                           (215) 855-1111
                           Fax (215) 393-2784

Good luck

Hannah Banks
[email-masked]