Subject: SLATE ROOFING...1/3 the cost.

From: Andre Poulain <[email-masked]>
Date: 4 Aug 1995 17:05:31 GMT

SLATECO INTERNATIONAL INC.MFG.
                    ONTARIO, Canada
                    Fax:(905)333-9787
                    E-Mail [email-masked]

                    Contact: Andre Poulain

---

From: [email-masked] (Meror Krayenhoff)
Date: Sat, 12 Aug 95 15:55:04 PST

Tell me more.
sent via UUCP from: Raven Net, Salt Spring Island, BC, Canada