Subject: Sod Roof

From: dale <[email-masked]>
Date: Wed, 20 Mar 1996 08:45:55 +0000

Can anyone tell me where I can find information on the advantages and 
problems and proceedures involved with sod roof construction. 

dale

---

From: [email-masked] (Codyarch)
Date: 20 Mar 1996 23:39:42 -0500

If you would like to see a beautiful house w/ a sod roof look at Alvar
Aalto's Villa Marea.