Subject: Used/Surplus Solar Panels For Sale?

From: Alex Gong <[email-masked]>
Date: Tue, 25 Mar 1997 12:51:12 -0800

I'm looking for some used/surplus/blemished solar panels. Can someone
please tell me where I can get these panels.
Thank you.

---

From: [email-masked] (L Thwaits)
Date: 26 Mar 1997 00:04:54 GMT

Put me on that bandwagon -- I'm interested too!  Anyone with panels that
wants cash is someone I'd love to talk with.  Preferably within 350 miles
of Tucson / Phoenix area so I can come and pick up the units in person.

-Lorin Thwaits
In East Tucson, AZ
(520) 886-1421

PS: Even panels that are totally smashed are worth something to me.