Subject: Source for extruded cases for lighting?

From: [email-masked] (Greg Brown)
Date: 13 May 1995 15:58:57 +0100

Does anyone know of suppliers of the extruded metal cases used in
intelligent lighting fixtures?  I find it hard to believe that they
are all custom manufactured because they all look alike, especially in
the lower end systems.

Any help would be very much appreciated.
Thanks.

Greg
(More imaginative sig under construction)

---

From: [email-masked] (HGBII)
Date: 13 May 1995 14:17:29 -0400

Call Rick Edwards at EUA Nova Company in Smithfield, RI at (401)232-2300. 
He is the principal lighting designer for our company.  He has designed
several lines of fixtures using extrusions for us.