Subject: Re: Phone # for SID Meeting Please

From: [email-masked] (Stephen J Hart)
Date: Tue, 9 May 1995 03:14:47 GMT

In article <[email-masked]>
[email-masked] (LatigoOpti) writes:

> I think I would like to attend the SID (society for information display)
> meeting in Orlando in Late May or Early June.  Anyone have a phone number
> for additional information?
> John McDonald

Society for Information Display
1526 Brookhollow Drive, Suite 82
Santa Ana, CA 92705-5421

(714) 545 1526 switchboard
(714) 545 1547 fax
[email-masked]
http://www.display.org/sid

Stephen J Hart                      fax              +1 (714) 348-8665
Director of R&D                     e-mail            [email-masked]
                                    WWW URL         under construction

VOXEL, 26081 Merit Circle, #117,    The opinions and "facts" expressed
Laguna Hills, CA 92653-7017, USA    herein are not necessarily correct

---

From: [email-masked] (LatigoOpti)
Date: 8 May 1995 16:33:31 -0400

---

From: [email-masked] (Jonathan E. Hardis)
Date: Tue, 09 May 1995 17:53:41 -0500

> for additional information?

800-787-7477, or 703-413-3891  (Arlington, VA)

---

From: Peter.Keller@Eng@tm (Peter Keller)
Date: Fri, 12 May 1995 15:59:52 +0100

> for additional information?

John,

Palisades Institute handles the SID conference registration and
arrangements.  I think the phone number is 800-787-7477 or
703-413-3891.  If that doesn't work, let me know and I will get
an address for you.  The conference runs from May 21-26 and is
well worth attending if you have an interest in displays.

Pete Keller
Tektronix