Subject: Re: EISA?

From: Andreas Busse <[email-masked]>
Date: Wed, 11 Aug 93 14:15:43 +0200

> EISA is a pretty good bus, something like 6 times the bandwidth of ISA.

Agreed.

> Isn't it completely upward compatible from ISA (i.e. we can use it just
> like a ISA bus).

No, it's completely incompatibel, from all 3 points of view:
- connector (different pin spacing)
- hardware  (different signals)
- software  (probably, don't really know)

> I certainly wouldn't object to an EISA bus on the riscy board, and if
> the ARC chips support it it's practically free.

No, it wouldn't be free. The ARCset just has a few lines intended
to be used to control the Intel EISA chipset.

Again, quoted from the data sheets (uPD31432, page 107):

6.7 BUS SLAVE INTERFACES

The uPD31432 supports two types of external bus masters: 386-type bus
masters, and an EISA expansion bus interface based on the Intel 82350
EISA chipset.

[end of quoted material]

That means that we can

a) use the EISA bus (with all the advantages and disadvantages it has)
b) skip the EISA bus and make our own ISA interface
c) have no expansion bus at all.

Ok, we already had a discussion wether we want an expansion bus
or not and we decided to go with ISA.
Assuming we have all the really necessary stuff on-board, I would
go with EISA too. It would make the design faster again and it
offers more speed.
On the other hand, not one of the ISA cards people have would
be useful.

> I believe the ARC 100 manufacturing kits include plans for 3 EISA boards
> Etherenet/serial, audio/mouse, and video.  Whether we we use any of those
> would just be a price/performance decision.

I have different block diagram using the ARCset chips:

+-------+               +----------+          +------+
|  Vr	| SysAD Bus     | ARCset   |    +---->| DRAM |
| 4000	|<------------->| D31431x2 |<---|     +------+
|	|               | D31432x1 |    |     +------+
+-------+               +----------+    +---->| VRAM |
                             |                +------+
                             |
        I/O Bus (i386 Bus)   |                
    +----------------------->|<--------------------------+
    |                        |                           |
    |                   +---------+                      |
    |                   |  Buffer |                      |
    |                   +---------+                      |
    |                        |                           |
+-------+   -----------------+----------------------  +------+
| EISA  |   |     |    |     |     |    |    |     |  | Ether|
|Control|   |     |    |     |     |    |    |     |  | net  |
+-------+   |     |    |     |     |    |    |     |  +------+
    |    +------+ | +------+ | +------+ | +------+ |
    |    |Mouse | | | PROM | | | NV-  | | |  RT  | |
    |    |& Kbd | | |      | | | RAM  | | |Clock | |
  EISA   +------+ | +------+ | +------+ | +------+ |
  Bus             |          |          |          |
               +------+   +------+   +------+   +------+
               |Sound |   |Floppy|   | SCSI |   |Par. &|
               | Ctrl |   | Ctrl |   | Ctrl |   |Serial|
               +------+   +------+   +------+   +------+

This blockdiagram contains really *all* of what is needed.
Don't ask me why ethernet is unbuffered, this is perhaps
just a "bug".
The block diagram shows also that the EISA bus is
an option, which probably can be replaced by an ISA bus.

Andy

---

From: Dan Fishman <[email-masked]>
Date: Wed, 11 Aug 1993 06:36:36 -0600 (MDT)

> - software  (probably, don't really know)

You need to tell that to my motherboard.  ISA boards run just fine in EISA
slot connectors (I know, I do it).  The pin spacing is different  in the sense
that there are double the number of pins and they are spaced vertically one above another.  I don't know all the tech details, but ISA boards simply make
contact with only their required signals and do not interfere with the added
bus signals for EISA control.

> On the other hand, not one of the ISA cards people have would

WRONG AGAIN.  ALL ISA boards should work just fine in an EISA bus system.
Again I'm doing just that (though obviously I have'nt used EVERY ISA board).
For example, in my EISA bus I currently have EISA AHA1742, ISA Hercules
Graphics Station video, and I had a DEC ISA Ethernet Card (I forget the 
model) and a SONY CDU535 8-bit ISA bus interface  CDROM drive.  They
all worked just fine and cooperated without a hitch.

> ....... Specific design proposal omitted
>
> Andy
> 

Dan Fishman ([email-masked]) (W) (303) 469-6469 (Fax) (303) 465-4396