Subject: A poem making machine in its primitive state

From: Alex Mou <[email-masked]>
Date: Mon, 17 Oct 1994 23:19:29 PDT

Here is a real poem making machine. Enjoy.

A.M.
PS.Hope somebody can improve its performance!

-----------------------------------
1. Cut the program below and put it in a file called "xmas.c"
2. execute the command "cc -o xmas xmas.c"
3. execute the command "xmas"

--------------------------------CUT HERE --------------------------------------

#include <stdio.h>
main(t,_,a)
char
*
a;
{
        return!

0<t?
t<3?

main(-79,-13,a+
main(-87,1-_,
main(-86, 0, a+1 )

+a)):

1,
t<_?
main(t+1, _, a )
:3,

main ( -94, -27+t, a )
&&t == 2 ?_
<13 ?

main ( 2, _+1, "%s %d %d\n" )

:9:16:
t<0?
t<-72?
main( _, t,
"@n'+,#'/*{}w+/w#cdnr/+,{}r/*de}+,/*{*+,/w{%+,/w#q#n+,/#{l,+,/n{n+,/+#n+,/#;\
#q#n+,/+k#;*+,/'r :'d*'3,}{w+K w'K:'+}e#';dq#'l q#'+d'K#!/+k#;\
q#'r}eKK#}w'r}eKK{nl]'/#;#q#n'){)#}w'){){nl]'/+#n';d}rw' i;# ){nl]!/n{n#'; \
r{#w'r nc{nl]'/#{l,+'K {rw' iK{;[{nl]'/w#q#\
\
n'wk nw' iwk{KK{nl]!/w{%'l##w#' i; :{nl]'/*{q#'ld;r'}{nlwb!/*de}'c ;;\
{nl'-{}rw]'/+,}##'*}#nc,',#nw]'/+kd'+e}+;\
#'rdq#w! nr'/ ') }+}{rl#'{n' ')# }'+}##(!!/")
:
t<-50?
_==*a ?
putchar(31[a]):

main(-65,_,a+1)
:
main((*a == '/') + t, _, a + 1 )
:

0<t?

main ( 2, 2 , "%s")
:*a=='/'||

main(0,

main(-61,*a, "!ek;dc i@bK'(q)-[w]*%n+r3#l,{}:\nuwloca-O;m .vpbks,fxntdCeghiry")

,a+1);}

---

From: Alex Mou <[email-masked]>
Date: Thu, 20 Oct 1994 14:27:02 PDT

Somebody worte to me: (others might wonder about the same thing)
>
> I am surprised to see your program. Did you generate it with some other
> program? A little thing that I found is the 'a-' proceeds words starting
> from sixth day. Is it a little bug (due to some incorrect counting in
> recursion) or something else? I am just curious. Thank you.
>

I didn't wrote the program. I never understand it either, not even try to.
I would be happy if some guru out there can explain to me how it works.
"a-" is perfect english and not a bug. a-hacking means at hacking or being
hacking, I guess.

A.M.