Subject: Re: Moving around a MUD.

From: [email-masked] (McEWAN Shane)
Date: Wed, 10 Jun 92 12:01:01 +1000

Spoofing can, and I believe will, be a problem. It doesn't do much damage
on normal MUDs....apart from a bit of confusion. But on a client based MUD 
where commands actually change your attributes, spoofing would be a major
security problem.

How would the keys be impemented? There would have to be some way of knowing,
on the client level, whether a command is valid or a spoof.
================================================================================
Shane McEwan
CSIRO Division of        
Atmospheric Research   "Money talks. The secret is to hold onto it long enough"
Aspendale, Victoria                  to hear what it says."
Australia  3195                               - W.G.P.
+61 3 586 7503          
[email-masked]
================================================================================

---

From: Brennan Underwood <[email-masked]>
Date: Tue, 9 Jun 92 20:11:05 MDT

The way to prevent spoofing in my mind is thus:
1. Set a certain attribute as Hidden (so only wizards can read it)
2. Fill this attribute with your personal, changeable key.
3. Have every 'kemit' be prepended with the kemitter's name and your
key (since the master object is/will be set WIZARD)
4. Your client can decide whether to believe it or not.

This is how I have spoof-prevented moving around. Since MOVE is now
hidden, no-one but WIZARDs can echo it at you. It would complexify
things muchly, but might be worth it.

Also: cyberportals. I think anyone who is planning on making their system
distributable should make their system cyberportal-compatible.
Anyone agree/disagree?
-- 
[email-masked]