Subject: To collide or not to collide? That is the question...

From: [email-masked] (Lance Norskog)
Date: Tue, 25 Feb 92 13:26:46 PST

Just scanning it, I don't see how to make an object that
doesn't have the collision property.  Do all objects have
to collide, or do I have to go off and do non-colliders
separately after calling render_scene()?

There are lots of things that shouldn't collide.
For example, the Information Visualizer stuff includes
a 3D crosshair cursor which you move around to pick stuff.
Its fine for this thing to disappear behind objects, because
it has three lines out to the edge of the screen along it's
XYZ axes.  (In fact, it has four lines on each axis and lets
you size 3D bounding boxes.)

Lance Norskog
[email-masked]

---

From: Dave Stampe-Psy+Eng <dstamp@watserv1>
Date: Tue, 25 Feb 92 18:23:55 -0500

> From [email-masked] Tue Feb 25 18:14:35 1992
> From: [email-masked] (Lance Norskog)
> To: rend386@sunee
> Subject: To collide or not to collide? That is the question...
> 
> 

We're looking at collision detection.  Noncollidibles ("virtual" objects)
and division-by-area are a few of the techniques possible.  Basically,
there's just a set of flags for each objects.  Another set of flags might
be added to optimize collision, for example on axis-aligned objects
(tabletops, walls) or to allow simplified collision by bounding volume
only.

Lots of thought needed on this topic, but some stuff is settling down.

- Dave Stampe