Subject: DXF to OFF converter

From: Jim McGrath <[email-masked]>
Date: 24 Apr 92 17:33:04 GMT+1200

The major problem at this stage seems to be that 'walls' have two sides, so
for every plane two poly's must be generated. If a 'soccer ball' is wanted
that is only to be viewed from the outside, the converter must decide which
polys to destroy. This of course could be decided by placing a point in the
centre of the ball and selecting say 'outside only' from a menu, or
something???

What I mean is have 3 options,
                    both sides of a plane,
                    outside relative to something,
                 or inside      "     "    "

The first option is no sweat. The other options I need comments on.

Can anyone think of a good way of doing this? Perhaps interactively?

Suggestions Please.

--
Jim McGrath             [email-masked]
--

---

From: [email-masked] (Lance Norskog)
Date: Thu, 23 Apr 92 23:33:21 PDT

You can build the list of vertices of the object and decide if
its fully connected; i.e. if it can be seen into.  This sounds
like a lot of work when a person is going to run the program
and promptly look at the output.  You might as well make
backface choice done by the user.

People are smarter than computers :-)

Lance Norskog