Subject: racketball program

From: Chris Hand <[email-masked]>
Date: Fri, 23 Oct 92 01:47:13 BST

Hi,

I just downloaded the racket ball game, and on my PC
it bombs out with a "Divide Error".

I recompiled (after farting about with makefiles) and
it now runs, but the "Racket Dist" display always says
2147483647.  Does this mean that sphere_pretest() is
failing all the time??

I *did* manage to grasp the racket but I wasn't
expecting it.  Without the stereo there is no
way to judge depth (shadows on the floor of the court would
help).

Performance is worse than the other rend386 demos -- perhaps
this is due to processing the ball movement.  I reckon
rend386 has now reached the stage where you either use it only
as a rendering engine, say on a  network, or you stick
some multi-tasking stuff underneath it (make it real time,
why not).  I know which is easier.

It would be nice to think the s/ware could be ported to
some OS more suitable than DOS, but I think this might
be too problematic.  I don't know enough about 386 assembler and
memory models to even know if it's feasible.

At this stage in it's life cycle it seems like rend386 has 
achieved critical mass... There's a very real possibility
that if any more stuff is added ad-hoc then it will fall apart.
For example, there's so much stuff in global variables that
it's easy to write code that stamps on stuff it shouldn't.  

I'm not complaining, just pointing out the dangers.  Bernie
and Dave have achieved a lot in a short time and shown just
what can be done on a PC.  So do we start again from scratch,
re-write some of the stuff, put together a programmer's
code-of-practice or what?  Any ideas?

Chris

---

From: "Michael L. Kaufman" <[email-masked]>
Date: Sat, 24 Oct 92 19:43:52 CDT

Chris Hand writes:
> be too problematic.  

Far be it for me to interrupt anyone's DOS bashing - after all, it is one of
the more popular net-activities - but what are you talking about? The problem
with the program is not enough cycles. With all the problems DOS has, it isn't
a cycle-eater. Do you think that a multi-tasking OS would make this run faster?
Perhaps you think that a nice window-manager would be just the thing? Unless
you are planning on throwing out all the zippy graphics routines that Dave and
Bernie wrote, you can forget it. I haven't looked at the program yet, but if 
it's too slow, what it needs is optimization, not an O/S switch.

Michael