Subject: Animation & rendering

From: [email-masked] (Lance Norskog)
Date: Tue, 25 Feb 92 13:42:03 PST

This level of hardware is capable of cartoon-level pix,
not film-level pix.  I.e., it will not look "realistic",
whatever that means.  The Realism Fans all want to use film-style
motion depiction, where animation methods are more appropriate.

Animation has its own language for showing motion, completely
unlike film.  "Snap and stretch" means that an object elongates
in the direction of motion, then changes back to it's original
shape as it arrives.  So, a moving cube should become rectangular
and then cubical once again.  

A moving circle would become elliptical then circular once again.
Thus, you would represent it as an ellipse with the foci coincident.
As it moves, the foci spread apart then come together.

Instead of motion blur you would use "speed streaks", little
lines going away from the object's direction of motion.

Lance Norskog
[email-masked]

---

From: Dave Stampe-Psy+Eng <dstamp@watserv1>
Date: Tue, 25 Feb 92 18:18:31 -0500

> From [email-masked] Tue Feb 25 18:04:41 1992
> From: [email-masked] (Lance Norskog)
> To: rend386@sunee
> Subject: Animation & rendering
> 

REND386 is not meant to produce photorealistic or cartoon pictures.  It
is a VR graphics engine: it does "just good enough" graphics at high 
speed.  For realism, I suggest regenerating output as positions and using
a ray-tracer.

Speed streaks are really only appropriate to static or very slow scenes.
For example 1 fps would be appropriate.  They'd just clutter up a REND386
image-- especially in a real-time interactive VR system.

If you really want to distort objects, go ahead!  Recreate the object for erame, then polygonize and add to the object list.  That's how ThingWorld
displays its stuff.  But you'll find the speed is pretty poor.

- Dave Stampe