Subject: Rend386 - Compile with DJGCC?

From: [email-masked] (Adrian Smith)
Date: Mon, 20 Jul 92 8:48:06 WST

Is it possible to compile rend386 with djgcc (dos port of gcc, gnu C compiler)?

Djgcc stores its libraries in a different format, I believe.

Adrian Smith
[email-masked]

---

From: Dave Stampe-Psy+Eng <dstamp@watserv1>
Date: Mon, 20 Jul 92 08:49:27 -0400

> From [email-masked] Sun Jul 19 21:48:56 1992
> From: [email-masked] (Adrian Smith)
> Subject: Rend386 - Compile with DJGCC?
> To: rend386@sunee
> 

With the next release, all the source will be available.  But since there
are quite a few Borland-specific keywords and inline assembler, some
reformatting might be required.

- Dave Stampe

---

From: [email-masked] (Technically Sweet)
Date: Mon, 20 Jul 92 13:39:53 PDT

Ha!

DJGCC creates programs for 32-bit mode, not 16-bit mode.
The assembler has a completely different format.  No,
you're stuck with this DOS shit unless you do a complete
rewrite.

Fully addressable 32-bit RAM.  Think about it.

Lance Norskog

---

From: Dave Stampe-Psy+Eng <dstamp@watserv1>
Date: Mon, 20 Jul 92 19:46:21 -0400

> From [email-masked] Mon Jul 20 16:46:34 1992
> From: [email-masked] (Technically Sweet)
> To: rend386@sunee
> Subject: Re: Rend386 - Compile with DJGCC?
> 
> Ha!
> 

If I had found a DECENT environment to program in (similar to Borland's IDE)
I probably would have developed the REND386 kernal with it, and put in
a DOS-code interface, much like BC 3.0 seems to be doing.  Ah, well...

- Dave Stampe