Subject: SEGA glasses interface circuit

From: Chris Hand <[email-masked]>
Date: 25 May 92 0:38 +0100

I just built the SEGA glasses interface that uses the RS-232 port,
as posted to usenet by [email-masked] sometime last September.

Using the version of the rend386 demo that supports the SEGA specs
(segademo.zip) seems to work, but there's a problem with the
glasses not being opaque at the right times.

The graphics for the left eye are fine: if I close my right eye I
can't see the letter "R" at the top of the screen.  If I close
my *left* eye, however, I can see the "R" clearly as well as
the letter "L" flickering on and off.

Has anyone else has this problem?  Presumably it's something
to do with the pulses that are being sent to the glove not
being exactly out of phase?   Can anyone explain what the
connections to the glasses' jack are?

I got best results by turning the contrast down on the monitor
(monochrome VGA) and switching the lights off in my study.
Makes using the keyboard a little difficult though... ;-)

Any comments/ideas/hints appreciated.

Cheers!

Chris

Chris Hand, Lecturer              | Internet mail: [email-masked]
Dept of Comp Sci, Leicester Poly, | Voice: +44 533 551551 x8476
PO Box 143, LEICESTER, UK LE1 9BH |   Fax: +44 533 541891  FIDOnet: 2:440/32.50

---

From: Dave Stampe-Psy+Eng <dstamp@watserv1>
Date: Mon, 25 May 92 00:32:23 -0400

One reason for switching problems could be that you can see the letter thru
one of the edges of the Sega glasses' windows.  The greatest opaqueness is at the center of the windows-- there is almost none at the sides.  Also, check to
see if any double images are seen.  Expand a view until the figure intersects
the top and bottom of the screen.  If there is a narrow band of double image
at the top or bottom of the screen, the glasses driver interrupt is not loacking properly.

-Dave Stampe