Subject: REND386 compilation

From: [email-masked]
Date: Thu, 16 Jul 92 08:31:53 MDT

Anybody else having trouble compiling REND386 demo3?  Using Turbo C++ 3.0 I
get the error messages shown below?  Are my problems related to lack of
REN386.lib sources (as pointed out by Lance Norskog)?  Any help would be
much appreciated.

--------------------  screen dump -------------------------------
MAKE Version 3.6  Copyright (c) 1991 Borland International

Available memory 3161440 bytes

       tcc -ml demo3.obj color256.obj pcxmodey.obj demo.lib sega.lib
userint.lib rend386.lib blit256.lib

Turbo C++ Version 3.00 Copyright (c) 1992 Borland International
Turbo Link  Version 5.0 Copyright (c) 1992 Borland International
Error: Fixup overflow at _TEXT:037E, target = _initialize_screen_factors in
library file demo.lib in module STEREOV
Error: Fixup overflow at _TEXT:0354, target = _m_mult in library file
demo.lib in module STEREOV
Error: Fixup overflow at _TEXT:033C, target = _m_mult in library file
demo.lib in module STEREOV
Error: Fixup overflow at _TEXT:0324, target = _m_mult in library file
demo.lib in module STEREOV
Error: Fixup overflow at .........
....... AND SO FORTH.
----------------------- end screen dump ----------------------------

--
tkl
--
---------------------------------------------------
T. K. Larson, Idaho National Engineering Laboratory
P.O. Box 1625, M/S 2090
Idaho Falls, Idaho 83415-2090
Phone (208) 525-5334; Fax (208) 525-5996
INTERNET: [email-masked]
---------------------------------------------------

---

From: [email-masked] (Joseph D. Gradecki)
Date: Thu, 16 Jul 92 09:22:56 -0600

The fixup error is due to different memory models.  Make sure that everything
is being compiled in LARGE model.  I was able to use the makefile for the
demo to compile the demo program.  

joe

---

From: [email-masked] (Technically Sweet)
Date: Thu, 16 Jul 92 10:57:55 PDT

Yes, those were the other errors I got.
I think the manual said those were benign error messages.

Lance Norskog

---

From: [email-masked]
Date: Thu, 16 Jul 92 12:13:04 MDT

>I think the manual said those were benign error messages.

Yes, Joe G's. suggestion worked.  On the REND386 demo3, recompile
mathinit.c and stereov.c with the large memory model (add lines to the
makefile or whatever) and all is well (at least with Turbo C++ V3).  In my
case the errors were not benign since everything blew up big time.
--
tkl
--
---------------------------------------------------
T. K. Larson, Idaho National Engineering Laboratory
P.O. Box 1625, M/S 2090
Idaho Falls, Idaho 83415-2090
Phone (208) 525-5334; Fax (208) 525-5996
INTERNET: [email-masked]
---------------------------------------------------

---

From: Dave Stampe-Psy+Eng <dstamp@watserv1>
Date: Thu, 16 Jul 92 17:24:02 -0400

The reason for fixup overflows is the ordering of the link.  Try to shift
the order and it should work.

- Dave Stampe
The order I use with BC:
rend3dis
matrix
mathinit
3dsupp
joystick
mouse
userint
sgint
sgsppt
glovedel
stereov
demo3
plg
pointer
render
segio
segment
color256
pcxmodey
fx3dkit
fbxblit
fmpmaskx
fmultpx
ftribltx
gxsppt
maskxtri
vgaxline

Some of these may have been chanded or added.