Subject: Port to sparc/X?

From: [email-masked] (Tom Bannon)
Date: Tue, 11 Feb 92 16:55:26 CST

Does anyone have any plans to port the rend386 package to a sparc and/or X
environment?

Can anyone comment on the speedups/slowdowns one might expect from doing
so?  Where would the bottlenecks be?

Thanks,
Tom Bannon

[email-masked]

---

From: Dave Stampe-Psy+Eng <dstamp@watserv1>
Date: Tue, 11 Feb 92 18:12:09 -0500

> From [email-masked] Tue Feb 11 18:01:09 1992
> From: [email-masked] (Tom Bannon)
> To: rend386@sunee
> Subject: Port to sparc/X?
> 
> 

Well, you'd probably be doing it in C and flating point.  There's a lot of
variation between machines, so no way of telling what the speed will be.

Second, you may notice the layers of structure indirection and loops in the
C code.  Unrolling these might help.

Finally, if the grphics environment can't do fast screen clears and
4000 or more 100-point polys/sec, it won't get great speed.

- Dave Stampe