Subject: Re: Speeders, FYI

From: Tom Glaab <[email-masked]>
Date: 26 Apr 1995 16:04:30 GMT

[email-masked] (Ed Tuthill) wrote:
> ObDriving:  Anyone heard anything recently about the MD highway bill to
> raise the speed limits?  Last I'd heard, it had passed one of the
> houses...

it takes effect 1 july 95, though it's not "official" on a stretch of highway
until the signs have been changed to say "65".

---

From: [email-masked] (Mark Robinowitz)
Date: Wed, 03 May 95 08:03:29 GMT